Out-of-bounds Write Affecting exim4 package, versions <4.94.2-5


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-EXIM4-2976423
  • published 8 Aug 2022
  • disclosed 7 Aug 2022

How to fix?

Upgrade Debian:11 exim4 to version 4.94.2-5 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See How to fix? for Debian:11 relevant versions.

Exim before 4.95 has a heap-based buffer overflow for the alias list in host_name_lookup in host.c when sender_host_name is set.