Use After Free Affecting expat package, versions <2.2.10-2+deb11u4


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical
Expand this section
Red Hat
8.1 high
Expand this section
SUSE
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-EXPAT-3023031
  • published 14 Sep 2022
  • disclosed 14 Sep 2022

How to fix?

Upgrade Debian:11 expat to version 2.2.10-2+deb11u4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream expat package and not the expat package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

libexpat before 2.4.9 has a use-after-free in the doContent function in xmlparse.c.