Use After Free Affecting expat package, versions <2.2.10-2+deb11u5


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
7.5 high
Expand this section
Red Hat
7.5 high
Expand this section
SUSE
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-EXPAT-3061093
  • published 25 Oct 2022
  • disclosed 24 Oct 2022

How to fix?

Upgrade Debian:11 expat to version 2.2.10-2+deb11u5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream expat package and not the expat package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

In libexpat through 2.4.9, there is a use-after free caused by overeager destruction of a shared DTD in XML_ExternalEntityParserCreate in out-of-memory situations.