CVE-2020-6105 Affecting f2fs-tools package, versions <1.14.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.1% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-F2FSTOOLS-1018783
  • published16 Oct 2020
  • disclosed15 Oct 2020

Introduced: 15 Oct 2020

CVE-2020-6105  (opens in a new tab)

How to fix?

Upgrade Debian:11 f2fs-tools to version 1.14.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream f2fs-tools package and not the f2fs-tools package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

An exploitable code execution vulnerability exists in the multiple devices functionality of F2fs-Tools F2fs.Fsck 1.13. A specially crafted f2fs filesystem can cause Information overwrite resulting in a code execution. An attacker can provide a malicious file to trigger this vulnerability.

CVSS Base Scores

version 3.1