Information Exposure Affecting glance package, versions <2012.1.1-5



    Attack Complexity Low
    User Interaction Required
Expand this section
3.5 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-GLANCE-521550
  • published 22 Mar 2013
  • disclosed 22 Mar 2013

How to fix?

Upgrade Debian:11 glance to version 2012.1.1-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

The v1 API in OpenStack Glance Essex (2012.1), Folsom (2012.2), and Grizzly, when using the single-tenant Swift or S3 store, reports the location field, which allows remote authenticated users to obtain the operator's backend credentials via a request for a cached image.