Information Exposure Affecting glance package, versions <2012.1.1-5


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.72% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-GLANCE-521550
  • published22 Mar 2013
  • disclosed22 Mar 2013

Introduced: 22 Mar 2013

CVE-2013-1840  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Debian:11 glance to version 2012.1.1-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

A flaw was found in OpenStack Glance. Remote authenticated users can exploit this vulnerability by requesting a cached image when the single-tenant Swift or S3 store is in use. This action causes the system to report the location field, which can lead to the disclosure of the operator's backend credentials.

CVSS Base Scores

version 3.1