Resource Management Errors Affecting glance package, versions <2015.1.0-4


Severity

0.0
medium
0
10

    Threat Intelligence

    EPSS
    0.28% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-GLANCE-532181
  • published 14 Aug 2015
  • disclosed 14 Aug 2015

How to fix?

Upgrade Debian:11 glance to version 2015.1.0-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream glance package and not the glance package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

OpenStack Glance before 2015.1.1 (kilo) allows remote authenticated users to cause a denial of service (disk consumption) by repeatedly using the import task flow API to create images and then deleting them.

CVSS Scores

version 3.1
Expand this section

Snyk

4.3 medium
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    Low
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    None
  • Integrity (I)
    None
  • Availability (A)
    Low
Expand this section

NVD

4.3 medium
Expand this section

Red Hat

3.5 low