Improper Certificate Validation Affecting golang-1.15 package, versions <1.15.5-1



    Attack Complexity Low
    Availability High
Expand this section
7.5 high
Expand this section
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-GOLANG115-1040406
  • published 15 Nov 2020
  • disclosed 18 Nov 2020

How to fix?

Upgrade Debian:11 golang-1.15 to version 1.15.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-1.15 package and not the golang-1.15 package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

Go before 1.14.12 and 1.15.x before 1.15.4 allows Denial of Service.