CVE-2021-33198 Affecting golang-1.15 package, versions <1.15.9-5


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.37% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-GOLANG115-1300530
  • published6 Jun 2021
  • disclosed2 Aug 2021

Introduced: 6 Jun 2021

CVE-2021-33198  (opens in a new tab)

How to fix?

Upgrade Debian:11 golang-1.15 to version 1.15.9-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-1.15 package and not the golang-1.15 package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

In Go before 1.15.13 and 1.16.x before 1.16.5, there can be a panic for a large exponent to the math/big.Rat SetString or UnmarshalText method.

CVSS Base Scores

version 3.1