Information Exposure Affecting imagemagick package, versions *


low

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
7.5 high
Expand this section
SUSE
4.7 medium
Expand this section
Red Hat
5.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-IMAGEMAGICK-1246513
  • published 22 Apr 2021
  • disclosed 11 May 2021

How to fix?

There is no fixed version for Debian:11 imagemagick.

NVD Description

Note: Versions mentioned in the description apply only to the upstream imagemagick package and not the imagemagick package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

A flaw was found in ImageMagick in versions before 7.0.11. A potential cipher leak when the calculate signatures in TransformSignature is possible. The highest threat from this vulnerability is to data confidentiality.

References