Integer Overflow or Wraparound Affecting imagemagick package, versions *


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high
Expand this section
Red Hat
3.3 low
Expand this section
SUSE
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-IMAGEMAGICK-2928981
  • published 17 Jun 2022
  • disclosed 16 Jun 2022

How to fix?

There is no fixed version for Debian:11 imagemagick.

NVD Description

Note: Versions mentioned in the description apply only to the upstream imagemagick package and not the imagemagick package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

A vulnerability was found in ImageMagick, causing an outside the range of representable values of type 'unsigned long' at coders/pcl.c, when crafted or untrusted input is processed. This leads to a negative impact to application availability or other problems related to undefined behavior.

References