Access of Resource Using Incompatible Type ('Type Confusion') Affecting lasso package, versions <2.6.1-3+deb11u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.09% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-LASSO-13842079
  • published6 Nov 2025
  • disclosed5 Nov 2025

Introduced: 5 Nov 2025

CVE-2025-47151  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade Debian:11 lasso to version 2.6.1-3+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lasso package and not the lasso package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

A type confusion vulnerability exists in the lasso_node_impl_init_from_xml functionality of Entr&#39;ouvert Lasso 2.5.1 and 2.8.2. A specially crafted SAML response can lead to an arbitrary code execution. An attacker can send a malformed SAML response to trigger this vulnerability.

CVSS Base Scores

version 3.1