Out-of-bounds Write Affecting libde265 package, versions <1.0.11-0+deb11u1



    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-LIBDE265-1585997
  • published 17 Sep 2021
  • disclosed 16 Sep 2021

How to fix?

Upgrade Debian:11 libde265 to version 1.0.11-0+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libde265 package and not the libde265 package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

libde265 v1.0.4 contains a heap buffer overflow in the de265_image::available_zscan function, which can be exploited via a crafted a file.