Buffer Overflow Affecting libeconf package, versions <0.3.8-1+deb11u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.64% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-LIBECONF-5671007
  • published8 Jun 2023
  • disclosed1 Jun 2023

Introduced: 1 Jun 2023

CVE-2023-22652  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Debian:11 libeconf to version 0.3.8-1+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libeconf package and not the libeconf package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

A Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in openSUSE libeconf leads to DoS via malformed config files. This issue affects libeconf: before 0.5.2.

CVSS Base Scores

version 3.1