Integer Overflow or Wraparound Affecting libksba package, versions <1.5.0-3+deb11u1


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical
Expand this section
Red Hat
8.1 high
Expand this section
SUSE
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-LIBKSBA-3050753
  • published 18 Oct 2022
  • disclosed 12 Jan 2023

How to fix?

Upgrade Debian:11 libksba to version 1.5.0-3+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libksba package and not the libksba package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

A vulnerability was found in the Libksba library due to an integer overflow within the CRL parser. The vulnerability can be exploited remotely for code execution on the target system by passing specially crafted data to the application, for example, a malicious S/MIME attachment.

References