Out-of-bounds Write Affecting liblouis package, versions <3.5.0-4


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.2% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-LIBLOUIS-520377
  • published9 Jun 2018
  • disclosed9 Jun 2018

Introduced: 9 Jun 2018

CVE-2018-12085  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:11 liblouis to version 3.5.0-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis package and not the liblouis package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Liblouis 3.6.0 has a stack-based Buffer Overflow in the function parseChars in compileTranslationTable.c, a different vulnerability than CVE-2018-11440.