Out-of-bounds Read Affecting libtasn1-6 package, versions <4.16.0-2+deb11u1


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Availability High
Expand this section
NVD
9.1 critical
Expand this section
SUSE
9.1 critical
Expand this section
Red Hat
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-LIBTASN16-3061097
  • published 25 Oct 2022
  • disclosed 24 Oct 2022

How to fix?

Upgrade Debian:11 libtasn1-6 to version 4.16.0-2+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libtasn1-6 package and not the libtasn1-6 package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

GNU Libtasn1 before 4.19.0 has an ETYPE_OK off-by-one array size check that affects asn1_encode_simple_der.