Incorrect Default Permissions Affecting libzstd package, versions <1.4.8+dfsg-1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High

    Threat Intelligence

    EPSS 0.06% (26th percentile)
Expand this section
NVD
5.5 medium
Expand this section
SUSE
6.2 medium
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-LIBZSTD-1080892
  • published 2 Mar 2021
  • disclosed 4 Mar 2021

How to fix?

Upgrade Debian:11 libzstd to version 1.4.8+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libzstd package and not the libzstd package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

In the Zstandard command-line utility prior to v1.4.1, output files were created with default permissions. Correct file permissions (matching the input) would only be set at completion time. Output files could therefore be readable or writable to unintended parties.