Race Condition Affecting libzstd package, versions <1.3.8+dfsg-2



    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 2.34% (90th percentile)
Expand this section
8.1 high
Expand this section
Red Hat
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-LIBZSTD-517447
  • published 26 Jul 2019
  • disclosed 25 Jul 2019

How to fix?

Upgrade Debian:11 libzstd to version 1.3.8+dfsg-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libzstd package and not the libzstd package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

A race condition in the one-pass compression functions of Zstandard prior to version 1.3.8 could allow an attacker to write bytes out of bounds if an output buffer smaller than the recommended size was used.