SQL Injection Affecting mariadb-10.5 package, versions *


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-MARIADB105-2766429
  • published 16 Apr 2022
  • disclosed 12 Apr 2022

How to fix?

There is no fixed version for Debian:11 mariadb-10.5.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mariadb-10.5 package and not the mariadb-10.5 package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

An issue in the component Used_tables_and_const_cache::used_tables_and_const_cache_join of MariaDB Server v10.7 and below was discovered to allow attackers to cause a Denial of Service (DoS) via specially crafted SQL statements.

References