Cross-site Scripting (XSS) Affecting mathjax package, versions <2.7.4+dfsg-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.45% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-MATHJAX-522237
  • published23 Jul 2018
  • disclosed23 Jul 2018

Introduced: 23 Jul 2018

CVE-2018-1999024  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:11 mathjax to version 2.7.4+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mathjax package and not the mathjax package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

MathJax version prior to version 2.7.4 contains a Cross Site Scripting (XSS) vulnerability in the \unicode{} macro that can result in Potentially untrusted Javascript running within a web browser. This attack appear to be exploitable via The victim must view a page where untrusted content is processed using Mathjax. This vulnerability appears to have been fixed in 2.7.4 and later.