Cryptographic Issues Affecting mcollective package, versions <1.2.1+dfsg-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.38% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-MCOLLECTIVE-531593
  • published5 May 2014
  • disclosed5 May 2014

Introduced: 5 May 2014

CVE-2014-0164  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:11 mcollective to version 1.2.1+dfsg-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mcollective package and not the mcollective package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

openshift-origin-broker-util, as used in Red Hat OpenShift Enterprise 1.2.7 and 2.0.5, uses world-readable permissions for the mcollective client.cfg configuration file, which allows local users to obtain credentials and other sensitive information by reading the file.

CVSS Base Scores

version 3.1