Use After Free Affecting nasm package, versions <2.13.02-0.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.08% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-NASM-519359
  • published2 Dec 2018
  • disclosed12 Nov 2018

Introduced: 12 Nov 2018

CVE-2018-19216  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:11 nasm to version 2.13.02-0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nasm package and not the nasm package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Netwide Assembler (NASM) before 2.13.02 has a use-after-free in detoken at asm/preproc.c.