Out-of-bounds Read Affecting ncurses package, versions <6.2+20201114-2+deb11u1


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Availability High

    Threat Intelligence

    EPSS 0.1% (41st percentile)
Expand this section
NVD
7.1 high
Expand this section
SUSE
5.5 medium
Expand this section
Red Hat
6.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-NCURSES-2767191
  • published 19 Apr 2022
  • disclosed 18 Apr 2022

How to fix?

Upgrade Debian:11 ncurses to version 6.2+20201114-2+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ncurses package and not the ncurses package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

ncurses 6.3 before patch 20220416 has an out-of-bounds read and segmentation violation in convert_strings in tinfo/read_entry.c in the terminfo library.