CVE-2026-2950 Affecting node-lodash package, versions <4.17.21+dfsg+~cs8.31.173-1+deb11u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.33% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-NODELODASH-15929486
  • published8 Apr 2026
  • disclosed31 Mar 2026

Introduced: 31 Mar 2026

CVE-2026-2950  (opens in a new tab)

How to fix?

Upgrade Debian:11 node-lodash to version 4.17.21+dfsg+~cs8.31.173-1+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-lodash package and not the node-lodash package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

The _.unset and _.omit functions in Lodash are vulnerable to prototype pollution. The fix for CVE-2025-13465 only guards against string key members, so an attacker can bypass the check by passing array-wrapped path segments. This allows deletion of properties from built-in prototypes such as Object.prototype, Number.prototype, and String.prototype. The issue permits deletion of prototype properties but does not allow overwriting their original behavior. The issue is patched from 4.18.0 to 4.18.1 depending on the package: lodash, lodash-es, and lodash-amd in 4.18.1, and the standalone lodash.unset and lodash.omit packages in 4.18.0.

CVSS Base Scores

version 3.1