Improper Input Validation Affecting node-node-forge package, versions <0.10.0~dfsg-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.19% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-NODENODEFORGE-609597
  • published3 Sept 2020
  • disclosed1 Sept 2020

Introduced: 1 Sep 2020

CVE-2020-7720  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:11 node-node-forge to version 0.10.0~dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-node-forge package and not the node-node-forge package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

The package node-forge before 0.10.0 is vulnerable to Prototype Pollution via the util.setPath function. Note: Version 0.10.0 is a breaking change removing the vulnerable functions.

CVSS Base Scores

version 3.1