Directory Traversal Affecting node-send package, versions <0.9.4-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.34% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-NODESEND-521992
  • published8 Oct 2014
  • disclosed8 Oct 2014

Introduced: 8 Oct 2014

CVE-2014-6394  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:11 node-send to version 0.9.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-send package and not the node-send package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

visionmedia send before 0.8.4 for Node.js uses a partial comparison for verifying whether a directory is within the document root, which allows remote attackers to access restricted directories, as demonstrated using "public-restricted" under a "public" directory.

CVSS Base Scores

version 3.1