Improper Input Validation Affecting node-url-parse package, versions <1.4.7-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.65% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-NODEURLPARSE-546673
  • published5 Feb 2020
  • disclosed4 Feb 2020

Introduced: 4 Feb 2020

CVE-2020-8124  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:11 node-url-parse to version 1.4.7-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-url-parse package and not the node-url-parse package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Insufficient validation and sanitization of user input exists in url-parse npm package version 1.4.4 and earlier may allow attacker to bypass security checks.

CVSS Base Scores

version 3.1