Integer Underflow Affecting openexr package, versions <2.5.4-2+deb11u1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
NVD
5.5 medium
Expand this section
SUSE
5.3 medium
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-OPENEXR-1300562
  • published 7 Jun 2021
  • disclosed 8 Jun 2021

How to fix?

Upgrade Debian:11 openexr to version 2.5.4-2+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openexr package and not the openexr package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

An integer overflow leading to a heap-buffer overflow was found in the DwaCompressor of OpenEXR in versions before 3.0.1. An attacker could use this flaw to crash an application compiled with OpenEXR. This is a different flaw from CVE-2021-23215.