Out-of-Bounds Affecting openexr package, versions <2.5.4-2+deb11u1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
5.5 medium
Expand this section
SUSE
4 medium
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-OPENEXR-1304909
  • published 13 Jun 2021
  • disclosed 6 Jul 2021

How to fix?

Upgrade Debian:11 openexr to version 2.5.4-2+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openexr package and not the openexr package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

There's a flaw in OpenEXR's ImfDeepScanLineInputFile functionality in versions prior to 3.0.5. An attacker who is able to submit a crafted file to an application linked with OpenEXR could cause an out-of-bounds read. The greatest risk from this flaw is to application availability.