Integer Overflow or Wraparound Affecting openexr package, versions <2.5.4-2+deb11u1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
NVD
5.5 medium
Expand this section
SUSE
5.5 medium
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-OPENEXR-1913908
  • published 10 Nov 2021
  • disclosed 25 Mar 2022

How to fix?

Upgrade Debian:11 openexr to version 2.5.4-2+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openexr package and not the openexr package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

An integer overflow could occur when OpenEXR processes a crafted file on systems where size_t < 64 bits. This could cause an invalid bytesPerLine and maxBytesPerLine value, which could lead to problems with application stability or lead to other attack paths.