Out-of-bounds Write Affecting openexr package, versions <2.5.4-2+deb11u1



    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
5.5 medium
Expand this section
6.6 medium
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-OPENEXR-2329539
  • published 4 Jan 2022
  • disclosed 1 Jan 2022

How to fix?

Upgrade Debian:11 openexr to version 2.5.4-2+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openexr package and not the openexr package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

OpenEXR 3.1.x before 3.1.4 has a heap-based buffer overflow in Imf_3_1::LineCompositeTask::execute (called from IlmThread_3_1::NullThreadPoolProvider::addTask and IlmThread_3_1::ThreadPool::addGlobalTask). NOTE: db217f2 may be inapplicable.