Use After Free Affecting pcsc-lite package, versions <1.8.20-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.04% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-PCSCLITE-517275
  • published23 Feb 2017
  • disclosed23 Feb 2017

Introduced: 23 Feb 2017

CVE-2016-10109  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:11 pcsc-lite to version 1.8.20-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcsc-lite package and not the pcsc-lite package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.