Improper Certificate Validation Affecting perl package, versions *


low

Snyk CVSS

    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.21% (58th percentile)
Expand this section
NVD
8.1 high
Expand this section
SUSE
7.4 high
Expand this section
Red Hat
7.4 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-PERL-5489191
  • published 29 Apr 2023
  • disclosed 29 Apr 2023

How to fix?

There is no fixed version for Debian:11 perl.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl package and not the perl package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

CPAN.pm before 2.35 does not verify TLS certificates when downloading distributions over HTTPS.