Use of Insufficiently Random Values Affecting python-pysaml2 package, versions <4.5.0-4


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.89% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-PYTHONPYSAML2-531754
  • published17 Nov 2017
  • disclosed17 Nov 2017

Introduced: 17 Nov 2017

CVE-2017-1000246  (opens in a new tab)
CWE-330  (opens in a new tab)

How to fix?

Upgrade Debian:11 python-pysaml2 to version 4.5.0-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-pysaml2 package and not the python-pysaml2 package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Python package pysaml2 version 4.4.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak encryption of data.