HTTP Request Smuggling Affecting ruby2.7 package, versions <2.7.1-4


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High
Expand this section
NVD
7.5 high
Expand this section
SUSE
6.3 medium
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-RUBY27-1014541
  • published 30 Sep 2020
  • disclosed 6 Oct 2020

How to fix?

Upgrade Debian:11 ruby2.7 to version 2.7.1-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.7 package and not the ruby2.7 package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.