Out-of-bounds Read Affecting ruby2.7 package, versions *


low

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
7.5 high
Expand this section
SUSE
6.2 medium
Expand this section
Red Hat
6.2 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-RUBY27-2772801
  • published 21 Apr 2022
  • disclosed 9 May 2022

How to fix?

There is no fixed version for Debian:11 ruby2.7.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.7 package and not the ruby2.7 package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

There is a buffer over-read in Ruby before 2.6.10, 2.7.x before 2.7.6, 3.x before 3.0.4, and 3.1.x before 3.1.2. It occurs in String-to-Float conversion, including Kernel#Float and String#to_f.