CRLF Injection Affecting ruby-mail package, versions <2.6.1+dfsg1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.4% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-RUBYMAIL-529541
  • published12 Jun 2017
  • disclosed12 Jun 2017

Introduced: 12 Jun 2017

CVE-2015-9097  (opens in a new tab)
CWE-93  (opens in a new tab)

How to fix?

Upgrade Debian:11 ruby-mail to version 2.6.1+dfsg1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-mail package and not the ruby-mail package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

The mail gem before 2.5.5 for Ruby (aka A Really Ruby Mail Library) is vulnerable to SMTP command injection via CRLF sequences in a RCPT TO or MAIL FROM command, as demonstrated by CRLF sequences immediately before and after a DATA substring.

CVSS Base Scores

version 3.1