CVE-2020-35920 Affecting rust-socket2 package, versions <0.3.19-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.41% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-RUSTSOCKET2-1055159
  • published1 Jan 2021
  • disclosed31 Dec 2020

Introduced: 31 Dec 2020

CVE-2020-35920  (opens in a new tab)

How to fix?

Upgrade Debian:11 rust-socket2 to version 0.3.19-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rust-socket2 package and not the rust-socket2 package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

An issue was discovered in the socket2 crate before 0.3.16 for Rust. It has false expectations about the std::net::SocketAddr memory representation.

CVSS Base Scores

version 3.1