Link Following Affecting shadow package, versions <1:4.1.1-6


0.0
high
0
10

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.04% (10th percentile)
Expand this section
NVD
8.4 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-SHADOW-515644
  • published 9 Dec 2008
  • disclosed 9 Dec 2008

How to fix?

Upgrade Debian:11 shadow to version 1:4.1.1-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shadow package and not the shadow package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

/bin/login in shadow 4.0.18.1 in Debian GNU/Linux, and probably other Linux distributions, allows local users in the utmp group to overwrite arbitrary files via a symlink attack on a temporary file referenced in a line (aka ut_line) field in a utmp entry.