Improper Input Validation Affecting shadow package, versions <1:4.1.4.2+svn3283-3


0.0
medium
0
10

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.43% (75th percentile)
Expand this section
NVD
6.5 medium
Expand this section
Red Hat
4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-SHADOW-517564
  • published 19 Feb 2011
  • disclosed 19 Feb 2011

How to fix?

Upgrade Debian:11 shadow to version 1:4.1.4.2+svn3283-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shadow package and not the shadow package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Multiple CRLF injection vulnerabilities in (1) chfn and (2) chsh in shadow 1:4.1.4 allow local users to add new users or groups to /etc/passwd via the GECOS field.