OS Command Injection Affecting spice-vdagent package, versions <0.18.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.42% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-SPICEVDAGENT-523768
  • published20 Jan 2018
  • disclosed20 Jan 2018

Introduced: 20 Jan 2018

CVE-2017-15108  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Debian:11 spice-vdagent to version 0.18.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spice-vdagent package and not the spice-vdagent package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

spice-vdagent up to and including 0.17.0 does not properly escape save directory before passing to shell, allowing local attacker with access to the session the agent runs in to inject arbitrary commands to be executed.

CVSS Base Scores

version 3.1