Use After Free Affecting subversion package, versions <1.14.1-3+deb11u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
9.47% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN11-SUBVERSION-2635643
  • published13 Apr 2022
  • disclosed12 Apr 2022

Introduced: 12 Apr 2022

CVE-2022-24070  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:11 subversion to version 1.14.1-3+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion package and not the subversion package as distributed by Debian. See How to fix? for Debian:11 relevant fixed versions and status.

Subversion's mod_dav_svn is vulnerable to memory corruption. While looking up path-based authorization rules, mod_dav_svn servers may attempt to use memory which has already been freed. Affected Subversion mod_dav_svn servers 1.10.0 through 1.14.1 (inclusive). Servers that do not use mod_dav_svn are not affected.

CVSS Base Scores

version 3.1