Improper Input Validation Affecting tiff package, versions <4.2.0-1+deb11u3


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
NVD
5.5 medium
Expand this section
SUSE
3.3 low
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-TIFF-2987014
  • published 18 Aug 2022
  • disclosed 17 Aug 2022

How to fix?

Upgrade Debian:11 tiff to version 4.2.0-1+deb11u3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tiff package and not the tiff package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

libtiff's tiffcrop utility has a improper input validation flaw that can lead to out of bounds read and ultimately cause a crash if an attacker is able to supply a crafted file to tiffcrop.

References