Out-of-bounds Write Affecting unzip package, versions <6.0-26+deb11u1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
NVD
5.5 medium
Expand this section
SUSE
4.7 medium
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN11-UNZIP-2396445
  • published 9 Feb 2022
  • disclosed 9 Feb 2022

How to fix?

Upgrade Debian:11 unzip to version 6.0-26+deb11u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unzip package and not the unzip package as distributed by Debian:11. See How to fix? for Debian:11 relevant fixed versions and status.

A flaw was found in Unzip. The vulnerability occurs during the conversion of a wide string to a local string that leads to a heap of out-of-bound write. This flaw allows an attacker to input a specially crafted zip file, leading to a crash or code execution.