Divide By Zero Affecting djvulibre package, versions <3.5.28-2.2~deb12u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.03% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN12-DJVULIBRE-5858454
  • published25 Aug 2023
  • disclosed22 Aug 2023

Introduced: 22 Aug 2023

CVE-2021-46310  (opens in a new tab)
CWE-369  (opens in a new tab)

How to fix?

Upgrade Debian:12 djvulibre to version 3.5.28-2.2~deb12u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream djvulibre package and not the djvulibre package as distributed by Debian. See How to fix? for Debian:12 relevant fixed versions and status.

An issue was discovered IW44Image.cpp in djvulibre 3.5.28 in allows attackers to cause a denial of service via divide by zero.

CVSS Base Scores

version 3.1