Out-of-bounds Write Affecting exim4 package, versions <4.92.2-3


0.0
critical

Snyk CVSS

    Exploit Maturity Mature
    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN12-EXIM4-1544888
  • published 27 Sep 2019
  • disclosed 27 Sep 2019

How to fix?

Upgrade Debian:12 exim4 to version 4.92.2-3 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See How to fix? for Debian:12 relevant versions.

Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846. There is a heap-based buffer overflow in string_vformat in string.c involving a long EHLO command.