Use After Free Affecting exim4 package, versions <4.89-12


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN12-EXIM4-1545061
  • published 25 Nov 2017
  • disclosed 25 Nov 2017

How to fix?

Upgrade Debian:12 exim4 to version 4.89-12 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See How to fix? for Debian:12 relevant versions.

The receive_msg function in receive.c in the SMTP daemon in Exim 4.88 and 4.89 allows remote attackers to execute arbitrary code or cause a denial of service (use-after-free) via vectors involving BDAT commands.