Improper Data Handling Affecting exim4 package, versions <4.92-10


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN12-EXIM4-1545071
  • published 24 Jul 2019
  • disclosed 25 Jul 2019

How to fix?

Upgrade Debian:12 exim4 to version 4.92-10 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See How to fix? for Debian:12 relevant versions.

Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).