Out-of-bounds Write Affecting exim4 package, versions <4.94.2-1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN12-EXIM4-1545350
  • published 5 May 2021
  • disclosed 6 May 2021

How to fix?

Upgrade Debian:12 exim4 to version 4.94.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See How to fix? for Debian:12 relevant versions.

Exim 4 before 4.94.2 allows Out-of-bounds Write because the main function, while setuid root, copies the current working directory pathname into a buffer that is too small (on some common platforms).

References