Out-of-bounds Write Affecting exim4 package, versions <4.94.2-5


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DEBIAN12-EXIM4-2976421

  • published

    8 Aug 2022

  • disclosed

    7 Aug 2022

How to fix?

Upgrade Debian:12 exim4 to version 4.94.2-5 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream exim4 package. See How to fix? for Debian:12 relevant versions.

Exim before 4.95 has a heap-based buffer overflow for the alias list in host_name_lookup in host.c when sender_host_name is set.